[GCC-XML] gccxml and the latest GCC

Trevor Trevor.Haba at logmein.com
Tue Jun 18 05:41:31 EDT 2013


I am trying to use gccxml on a large code base to produce XML descriptions of 
the individual header files. However, I am running into a problem compiling 
code written in the latest C++11. My specific issue is this:

enum A : int 
{ ... }

error: expected primary-expression before 'int'
error: expected ';' before 'int'

So clearly my version of gccxml is using an older version of the gcc C++ 
compiler. Invoking gcc --version gives me gcc (GCC) 4.7.2, which I thought was 
up to date enough to handle the latest C++11 features. 

Regardless, I am somewhat confused as to how to tell the gccxml process which 
compiler to use. I have tried the flag --gccxml-compiler with cl, which gives 
me the exact same problem, even though I can compile the project just fine 
within visual studio itself. When I run --gccxml-compiler gcc it tells me it 
cannot find gcc (the same thing happens when I enter g++). 

For reference, I forked the gccxml depot, used the CMake GUI targeting Visual 
Studio 2010, and then built gccxml from the visual studio project created by 
CMake. It works just fine on everything but the latest C++11 features.

Can anyone give me some advice on how to resolve this issue?
Thanks very much,

More information about the gccxml mailing list